What’s Vulnerable › Vulnerabilities
CVE-2026-21580
- Severity: critical (CVSS 9.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-08-26
- Weakness: CWE-79
Description
This Critical severity Stored XSS, PrivEsc (Privilege Escalation), and Security Misconfiguration vulnerability was introduced in versions 7.1.1, 7.4.0, 7.13.0, 7.17.0, 7.19.0, 8.0.0, 8.5.0, 8.9.0, 9.0.1, 9.1.0, 9.2.0, 9.3.1, 9.4.0, 9.5.1, 10.0.2, 10.1.0 and 10.2.0 of Confluence Data Center and Server. This Stored XSS, PrivEsc (Privilege Escalation), and Security Misconfiguration vulnerability, with a CVSS Score of 8.6, allows an unauthenticated attacker to execute arbitrary HTML or JavaScript code on a victims browser, perform actions as a higher-privileged user, and to get into the system utilizing loopholes exposed from security best-practices being overlooked. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Confluence Data Center and Server 9.2: Upgrade to a release greater than or equal to 9.2.21 Confluence Data Center and Server 10.2: Upgrade to a release greater than or equal to 10.2.13 See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html]). You can download the latest version of Confluence Data Center and Server from the download center ([https://www.atlassian.com/software/confluence/download-archives]). This vulnerability was reported via our Bug Bounty program.
Affected products
- Atlassian Confluence Data Center: from 10.2.0 through 10.2.11; from 10.1.0 through 10.1.2; from 10.0.2 through 10.0.3; from 9.5.1 through 9.5.4; from 9.4.0 through 9.4.1; from 9.3.1 through 9.3.2
- Atlassian Confluence Data Center: from 8.5.15 through 8.5.31; from 7.19.27 through 7.19.30
References
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1821999768
- https://jira.atlassian.com/browse/CONFSERVER-104381
Get alerted when CVE-2026-21580 or the next vulnerability affects your stack