What’s Vulnerable › Vulnerabilities
CVE-2026-21629: Joomla! Core - [20260301] - ACL hardening in com_ajax
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-01 · updated 2026-10-26
- Weakness: CWE-284
Description
The ajax component was excluded from the default logged-in-user check in the administrative area. This behavior was potentially unexpected by 3rd party developers.
Affected products
- Joomla!: from 3.0.0 before 5.4.4; from 6.0.0 before 6.0.4 — fixed in 5.4.4, 6.0.4
How to fix
Upgrade to a fixed version: Joomla! 5.4.4, 6.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-21629 or the next vulnerability affects your stack