What’s Vulnerable › Vulnerabilities
CVE-2026-21636
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-20 · updated 2026-06-17
- Weakness: CWE-284
Description
A flaw in Node.js's permission model allows Unix Domain Socket (UDS) connections to bypass network restrictions when `--permission` is enabled. Even without `--allow-net`, attacker-controlled inputs (such as URLs or socketPath options) can connect to arbitrary local sockets via net, tls, or undici/fetch. This breaks the intended security boundary of the permission model and enables access to privileged local services, potentially leading to privilege escalation, data exposure, or local code execution. * The issue affects users of the Node.js permission model on version v25. In the moment of this vulnerability, network permissions (`--allow-net`) are still in the experimental phase.
Affected products
- Node.js: from 25.0.0 before 25.3.0 — fixed in 25.3.0
How to fix
Upgrade to a fixed version: Node.js 25.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-21636 or the next vulnerability affects your stack