What’s Vulnerable › Vulnerabilities
CVE-2026-21637
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-20 · updated 2026-06-17
- Weakness: CWE-400
Description
A flaw in Node.js TLS error handling allows remote attackers to crash or exhaust resources of a TLS server when `pskCallback` or `ALPNCallback` are in use. Synchronous exceptions thrown during these callbacks bypass standard TLS error handling paths (tlsClientError and error), causing either immediate process termination or silent file descriptor leaks that eventually lead to denial of service. Because these callbacks process attacker-controlled input during the TLS handshake, a remote client can repeatedly trigger the issue. This vulnerability affects TLS servers using PSK or ALPN callbacks across Node.js versions where these callbacks throw without being safely wrapped.
Affected products
- Node.js: from 4.0.0 before 20.20.0; from 22.0.0 before 22.22.0; from 24.0.0 before 24.13.0; from 25.0.0 before 25.3.0 — fixed in 20.20.0, 22.22.0, 24.13.0, 25.3.0
How to fix
Upgrade to a fixed version: Node.js 20.20.0, 22.22.0, 24.13.0, 25.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-21637 or the next vulnerability affects your stack