What’s Vulnerable › Vulnerabilities
CVE-2026-21711
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-30 · updated 2026-08-19
- Weakness: CWE-284
Description
A flaw in Node.js Permission Model network enforcement leaves Unix Domain Socket (UDS) server operations without the required permission checks, while all comparable network paths correctly enforce them. As a result, code running under `--permission` without `--allow-net` can create and expose local IPC endpoints, allowing communication with other processes on the same host outside of the intended network restriction boundary. This vulnerability affects Node.js **25.x** processes using the Permission Model where `--allow-net` is intentionally omitted to restrict network access. Note that `--allow-net` is currently an experimental feature.
Affected products
- Node.js: before 20.0.0; from 25.0.0 through 25.8.1 — fixed in 20.0.0
How to fix
Upgrade to a fixed version: Node.js 20.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-21711 or the next vulnerability affects your stack