What’s Vulnerable › Vulnerabilities
CVE-2026-21865: Discourse topic conversion permission vulnerability for moderators
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-28 · updated 2026-06-17
- Weakness: CWE-862
Description
Discourse is an open source discussion platform. In versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0, moderators can convert some personal messages to public topics when they shouldn't have access. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, site admin can temporarily revoke the moderation role from untrusted moderators or remove the moderator group from the "personal message enabled groups" site setting until the Discourse instance has been upgraded to a version that has been patched.
Affected products
- discourse: before 3.5.4; from 2025.11.0 before 2025.11.2; 2025.12.0, 2026.1.0 — fixed in 2025.11.2, 3.5.4
How to fix
Upgrade to a fixed version: discourse 2025.11.2, 3.5.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-21865 or the next vulnerability affects your stack