What’s Vulnerable › Vulnerabilities
CVE-2026-21871: NiceGUI is vulnerable to XSS via Unescaped URL in ui.navigate.history.push() / replace()
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-08 · updated 2026-06-17
- Weakness: CWE-79
Description
NiceGUI is a Python-based UI framework. From versions 2.13.0 to 3.4.1, there is a XSS risk in NiceGUI when developers pass attacker-controlled strings into ui.navigate.history.push() or ui.navigate.history.replace(). These helpers are documented as History API wrappers for updating the browser URL without page reload. However, if the URL argument is embedded into generated JavaScript without proper escaping, a crafted payload can break out of the intended string context and execute arbitrary JavaScript in the victim’s browser. Applications that do not pass untrusted input into ui.navigate.history.push/replace are not affected. This issue has been patched in version 3.5.0.
Affected products
- zauberzeug nicegui: from 2.13.0 before 3.5.0 — fixed in 3.5.0
How to fix
Upgrade to a fixed version: zauberzeug nicegui 3.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/zauberzeug/nicegui/releases/tag/v3.5.0
- https://github.com/zauberzeug/nicegui/security/advisories/GHSA-7grm-h62g-5m97
Get alerted when CVE-2026-21871 or the next vulnerability affects your stack