What’s Vulnerable › Vulnerabilities
CVE-2026-21877: n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-08 · updated 2026-06-17
- Weakness: CWE-94
Description
n8n is an open source workflow automation platform. In versions 0.121.2 and below, an authenticated attacker may be able to execute malicious code using the n8n service. This could result in full compromise and can impact both self-hosted and n8n Cloud instances. This issue is fixed in version 1.121.3. Administrators can reduce exposure by disabling the Git node and limiting access for untrusted users, but upgrading to the latest version is recommended.
Affected products
- n8n-io n8n: from 0.123.0 before 1.121.3 — fixed in 1.121.3
How to fix
Upgrade to a fixed version: n8n-io n8n 1.121.3. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/commit/f4b009d00d1f4ba9359b8e8f1c071e3d910a55f6
- https://github.com/n8n-io/n8n/security/advisories/GHSA-v364-rw7m-3263
Get alerted when CVE-2026-21877 or the next vulnerability affects your stack