What’s Vulnerable › Vulnerabilities
CVE-2026-21881: Kanboard is Vulnerable to Reverse Proxy Authentication Bypass
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-08 · updated 2026-06-17
- Weakness: CWE-287
Description
Kanboard is project management software focused on Kanban methodology. Versions 1.2.48 and below is vulnerable to a critical authentication bypass when REVERSE_PROXY_AUTH is enabled. The application blindly trusts HTTP headers for user authentication without verifying the request originated from a trusted reverse proxy. An attacker can impersonate any user, including administrators, by simply sending a spoofed HTTP header. This issue is fixed in version 1.2.49.
Affected products
- kanboard: before 1.2.49 — fixed in 1.2.49
How to fix
Upgrade to a fixed version: kanboard 1.2.49. Check the vendor advisory for mitigations.
References
- https://github.com/kanboard/kanboard/commit/7af6143e2ad25b5c15549cca8af4341c7ac4e2fc
- https://github.com/kanboard/kanboard/releases/tag/v1.2.49
- https://github.com/kanboard/kanboard/security/advisories/GHSA-wwpf-3j4p-739w
- https://github.com/kanboard/kanboard/security/advisories/GHSA-wwpf-3j4p-739w
Get alerted when CVE-2026-21881 or the next vulnerability affects your stack