What’s Vulnerable › Vulnerabilities
CVE-2026-21892: Parsl Monitoring Visualization Vulnerable to SQL Injection
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-08 · updated 2026-10-06
- Weakness: CWE-89
Description
Parsl is a Python parallel scripting library. A SQL Injection vulnerability exists in the parsl-visualize component of versions prior to 2026.01.05. The application constructs SQL queries using unsafe string formatting (Python % operator) with user-supplied input (workflow_id) directly from URL routes. This allows an unauthenticated attacker with access to the visualization dashboard to inject arbitrary SQL commands, potentially leading to data exfiltration or denial of service against the monitoring database. Version 2026.01.05 fixes the issue.
Affected products
- parsl: before 2026.01.05 — fixed in 2026.01.05
How to fix
Upgrade to a fixed version: parsl 2026.01.05. Check the vendor advisory for mitigations.
References
- https://github.com/Parsl/parsl/commit/013a928461e70f38a33258bd525a351ed828e974
- https://github.com/Parsl/parsl/security/advisories/GHSA-f2mf-q878-gh58
- https://github.com/Parsl/parsl/security/advisories/GHSA-f2mf-q878-gh58
Get alerted when CVE-2026-21892 or the next vulnerability affects your stack