What’s Vulnerable › Vulnerabilities
CVE-2026-21893: n8n Vulnerable to Command Injection in Community Package Installation
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-04 · updated 2026-06-17
- Weakness: CWE-20
Description
n8n is an open source workflow automation platform. From version 0.187.0 to before 1.120.3, a command injection vulnerability was identified in n8n’s community package installation functionality. The issue allowed authenticated users with administrative permissions to execute arbitrary system commands on the n8n host under specific conditions. This issue has been patched in version 1.120.3.
Affected products
- n8n-io n8n: from 0.187.0 before 1.120.3 — fixed in 1.120.3
How to fix
Upgrade to a fixed version: n8n-io n8n 1.120.3. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/commit/ae0669a736cc496beeb296e115267862727ae838
- https://github.com/n8n-io/n8n/security/advisories/GHSA-7c4h-vh2m-743m
Get alerted when CVE-2026-21893 or the next vulnerability affects your stack