What’s Vulnerable › Vulnerabilities
CVE-2026-22177: OpenClaw < 2026.2.21 - Environment Variable Injection via Config env.vars
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-18 · updated 2026-06-17
- Weakness: CWE-15
Description
OpenClaw versions prior to 2026.2.21 fail to filter dangerous process-control environment variables from config env.vars, allowing startup-time code execution. Attackers can inject variables like NODE_OPTIONS or LD_* through configuration to execute arbitrary code in the OpenClaw gateway service runtime context.
Affected products
- OpenClaw: before 2026.2.21 — fixed in 2026.2.21
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.21. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/2cdbadee1f8fcaa93302d7debbfc529e19868ea4
- https://github.com/openclaw/openclaw/security/advisories/GHSA-8fmp-37rc-p5g7
- https://github.com/openclaw/openclaw/security/advisories/GHSA-w9j9-w4cp-6wgr
- https://www.vulncheck.com/advisories/openclaw-environment-variable-injection-via-config-env-vars
Get alerted when CVE-2026-22177 or the next vulnerability affects your stack