What’s Vulnerable › Vulnerabilities
CVE-2026-22182: wpDiscuz before 7.6.47 - Unauthenticated Email Notification Flood via wpdCheckNotificationType
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-13 · updated 2026-06-17
- Weakness: CWE-862
Description
wpDiscuz before 7.6.47 contains an unauthenticated denial of service vulnerability that allows anonymous users to trigger mass notification emails by exploiting the checkNotificationType() function. Attackers can repeatedly call the wpdiscuz-ajax.php endpoint with arbitrary postId and comment_id parameters to flood subscribers with notifications, as the handler lacks nonce verification, authentication checks, and rate limiting.
Affected products
- gVectors wpDiscuz: before 7.6.47 — fixed in 7.6.47
How to fix
Upgrade to a fixed version: gVectors wpDiscuz 7.6.47. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/wpdiscuz/
- https://wordpress.org/plugins/wpdiscuz/#developers
- https://www.vulncheck.com/advisories/wpdiscuz-before-unauthenticated-email-notification-flood-via-wpdchecknotificationtype
Get alerted when CVE-2026-22182 or the next vulnerability affects your stack