What’s Vulnerable › Vulnerabilities
CVE-2026-22209: wpDiscuz before 7.6.47 - Cross-Site Scripting via Unescaped Custom CSS in Style Tag
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-13 · updated 2026-06-17
- Weakness: CWE-79
Description
wpDiscuz before 7.6.47 contains a cross-site scripting vulnerability in the customCss field that allows administrators to inject malicious scripts by breaking out of style tags. Attackers with admin access can inject payloads like </style><script>alert(1)</script> in the custom CSS setting to execute arbitrary JavaScript in user browsers.
Affected products
- gVectors wpDiscuz: before 7.6.47 — fixed in 7.6.47
How to fix
Upgrade to a fixed version: gVectors wpDiscuz 7.6.47. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/wpdiscuz/
- https://wordpress.org/plugins/wpdiscuz/#developers
- https://www.vulncheck.com/advisories/wpdiscuz-before-cross-site-scripting-via-unescaped-custom-css-in-style-tag
Get alerted when CVE-2026-22209 or the next vulnerability affects your stack