What’s Vulnerable › Vulnerabilities
CVE-2026-22213: RIOT OS <= 2026.01-devel-317 Stack-Based Buffer Overflow in tapslip6 Utility
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-12 · updated 2026-07-14
- Weakness: CWE-121
Description
RIOT OS versions up to and including 2026.01-devel-317 contain a stack-based buffer overflow vulnerability in the tapslip6 utility. The vulnerability is caused by unsafe string concatenation in the devopen() function, which constructs a device path using unbounded user-controlled input. The utility uses strcpy() and strcat() to concatenate the fixed prefix '/dev/' with a user-supplied device name provided via the -s command-line option without bounds checking. This allows an attacker to supply an excessively long device name and overflow a fixed-size stack buffer, leading to process crashes and memory corruption.
Affected products
- RIOT-OS RIOT: before 2025.10; 2026.01-devel, 2026.01-rc1 — fixed in 2025.10
How to fix
Upgrade to a fixed version: RIOT-OS RIOT 2025.10. Check the vendor advisory for mitigations.
References
- https://github.com/RIOT-OS/RIOT
- https://seclists.org/fulldisclosure/2026/Jan/15
- https://www.riot-os.org/
- https://www.vulncheck.com/advisories/riot-os-stack-based-buffer-overflow-in-tapslip6-utility
Get alerted when CVE-2026-22213 or the next vulnerability affects your stack