What’s Vulnerable › Vulnerabilities
CVE-2026-22215: wpDiscuz before 7.6.47 - Missing CSRF Protection on wpdGetFollowsPage
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-13 · updated 2026-06-17
- Weakness: CWE-352
Description
wpDiscuz before 7.6.47 contains a cross-site request forgery vulnerability in the getFollowsPage() function that allows attackers to trigger unauthorized actions without nonce validation. Attackers can craft malicious requests to enumerate follow relationships and manipulate user follow data by exploiting the missing CSRF protection in the follows page handler.
Affected products
- gVectors wpDiscuz: before 7.6.47 — fixed in 7.6.47
How to fix
Upgrade to a fixed version: gVectors wpDiscuz 7.6.47. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/wpdiscuz/
- https://wordpress.org/plugins/wpdiscuz/#developers
- https://www.vulncheck.com/advisories/wpdiscuz-before-missing-csrf-protection-on-wpdgetfollowspage
Get alerted when CVE-2026-22215 or the next vulnerability affects your stack