What’s Vulnerable › Vulnerabilities
CVE-2026-22216: wpDiscuz before 7.6.47 - No Rate Limiting on Subscription Endpoints with LIKE Wildcard Bypass
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-13 · updated 2026-06-17
- Weakness: CWE-799
Description
wpDiscuz before 7.6.47 contains a missing rate limiting vulnerability that allows unauthenticated attackers to subscribe arbitrary email addresses to post notifications by sending POST requests to the wpdAddSubscription handler in class.WpdiscuzHelperAjax.php. Attackers can exploit LIKE wildcard characters in the subscription query to match multiple email addresses and generate unwanted notification emails to victim accounts.
Affected products
- gVectors wpDiscuz: before 7.6.47 — fixed in 7.6.47
How to fix
Upgrade to a fixed version: gVectors wpDiscuz 7.6.47. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/wpdiscuz/
- https://wordpress.org/plugins/wpdiscuz/#developers
- https://www.vulncheck.com/advisories/wpdiscuz-before-no-rate-limiting-on-subscription-endpoints-with-like-wildcard-bypass
Get alerted when CVE-2026-22216 or the next vulnerability affects your stack