What’s Vulnerable › Vulnerabilities
CVE-2026-22217: OpenClaw 2026.2.22 < 2026.2.23 - Arbitrary Binary Execution via $SHELL Environment Variable Trusted Prefix Fallback
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-18 · updated 2026-06-17
- Weakness: CWE-829
Description
OpenClaw version 2026.2.22 prior to 2026.2.23 contains an arbitrary code execution vulnerability in shell-env that allows attackers to execute attacker-controlled binaries by exploiting trusted-prefix fallback logic for the $SHELL variable. An attacker can influence the $SHELL environment variable on systems with writable trusted-prefix directories such as /opt/homebrew/bin to execute arbitrary binaries in the OpenClaw process context.
Affected products
- OpenClaw: from 2026.2.22 before 2026.2.23 — fixed in 2026.2.23
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.23. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/ff10fe8b91670044a6bb0cd85deb736a0ec8fb55
- https://github.com/openclaw/openclaw/security/advisories/GHSA-p4wh-cr8m-gm6c
- https://www.vulncheck.com/advisories/openclaw-arbitrary-binary-execution-via-shell-environment-variable-trusted-prefix-fallback
Get alerted when CVE-2026-22217 or the next vulnerability affects your stack