What’s Vulnerable › Vulnerabilities
CVE-2026-22224: Command Injection Vulnerability on TP-Link Archer BE230 v1.2
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-02 · updated 2026-06-17
- Weakness: CWE-78
Description
A command injection vulnerability may be exploited after the admin's authentication in the cloud communication interface on the TP-Link Archer BE230 v1.2. Successful exploitation could allow an attacker to gain full administrative control of the device, resulting in severe compromise of configuration integrity, network security, and service availability. This CVE covers one of multiple distinct OS command injection issues identified across separate code paths. Although similar in nature, each instance is tracked under a unique CVE ID. This issue affects Archer BE230 v1.2 < 1.2.4 Build 20251218 rel.70420.
Affected products
- TP-Link Systems Inc. Archer BE230 v1.2: before 1.2.4 — fixed in 1.2.4
How to fix
Upgrade to a fixed version: TP-Link Systems Inc. Archer BE230 v1.2 1.2.4. Check the vendor advisory for mitigations.
References
- https://www.tp-link.com/en/support/download/archer-be230/v1.20/#Firmware
- https://www.tp-link.com/sg/support/download/archer-be230/v1.20/#Firmware
- https://www.tp-link.com/us/support/download/archer-be230/v1.20/#Firmware
- https://www.tp-link.com/us/support/faq/4935/
Get alerted when CVE-2026-22224 or the next vulnerability affects your stack