What’s Vulnerable › Vulnerabilities
CVE-2026-22249: Docmost affected by an Arbitrary File Write via Zip Import Feature (ZipSlip)
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-15 · updated 2026-06-17
- Weakness: CWE-22
Description
Docmost is an open-source collaborative wiki and documentation software. From 0.21.0 to before 0.24.0, Docmost is vulnerable to Arbitrary File Write via Zip Import Feature (ZipSlip). In apps/server/src/integrations/import/utils/file.utils.ts, there are no validation on filename. This vulnerability is fixed in 0.24.0.
Affected products
- docmost: from 0.21.0 before 0.24.0 — fixed in 0.24.0
How to fix
Upgrade to a fixed version: docmost 0.24.0. Check the vendor advisory for mitigations.
References
- https://github.com/docmost/docmost/commit/c3b350d943108552e20654580005cd6f6c78ab05
- https://github.com/docmost/docmost/pull/1753
- https://github.com/docmost/docmost/releases/tag/v0.24.0
- https://github.com/docmost/docmost/security/advisories/GHSA-54pm-hqxm-54wg
- https://github.com/docmost/docmost/security/advisories/GHSA-54pm-hqxm-54wg
Get alerted when CVE-2026-22249 or the next vulnerability affects your stack