What’s Vulnerable › Vulnerabilities
CVE-2026-22250: wlc can skip SSL verification
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-12 · updated 2026-06-17
- Weakness: CWE-295
Description
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.0, the SSL verification would be skipped for some crafted URLs. This vulnerability is fixed in 1.17.0.
Affected products
- WeblateOrg wlc: before 1.17.0 — fixed in 1.17.0
How to fix
Upgrade to a fixed version: WeblateOrg wlc 1.17.0. Check the vendor advisory for mitigations.
References
- https://github.com/WeblateOrg/wlc/commit/a513864ec4daad00146e6d6e039559726e256fa3
- https://github.com/WeblateOrg/wlc/pull/1097
- https://github.com/WeblateOrg/wlc/security/advisories/GHSA-2mmv-7rrp-g8xh
Get alerted when CVE-2026-22250 or the next vulnerability affects your stack