What’s Vulnerable › Vulnerabilities
CVE-2026-22559
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-20
Description
An Improper Input Validation vulnerability in UniFi Network Server may allow unauthorized access to an account if the account owner is socially engineered into clicking a malicious link. Affected Products: UniFi Network Server (Version 10.1.85 and earlier) Mitigation: Update UniFi Network Server to Version 10.1.89 or later.
Affected products
- Ubiquiti Inc UniFi Network Server: from 10.1.89 before 10.1.89 — fixed in 10.1.89
How to fix
Upgrade to a fixed version: Ubiquiti Inc UniFi Network Server 10.1.89. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-22559 or the next vulnerability affects your stack