What’s Vulnerable › Vulnerabilities
CVE-2026-22592: Gogs is Vulnerable to Denial of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-06 · updated 2026-06-17
- Weakness: CWE-862
Description
Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, an authenticated user can cause a DOS attack. If one of the repo files is deleted before synchronization, it will cause the application to crash. This issue has been patched in versions 0.13.4 and 0.14.0+dev.
Affected products
- gogs: before 0.13.4 — fixed in 0.13.4
How to fix
Upgrade to a fixed version: gogs 0.13.4. Check the vendor advisory for mitigations.
References
- https://github.com/gogs/gogs/security/advisories/GHSA-cr88-6mqm-4g57
- https://github.com/gogs/gogs/security/advisories/GHSA-cr88-6mqm-4g57
Get alerted when CVE-2026-22592 or the next vulnerability affects your stack