What’s Vulnerable › Vulnerabilities
CVE-2026-22610: Angular has XSS Vulnerability via Unsanitized SVG Script Attributes
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0, a cross-site scripting (XSS) vulnerability has been identified in the Angular Template Compiler. The vulnerability exists because Angular’s internal sanitization schema fails to recognize the href and xlink:href attributes of SVG <script> elements as a Resource URL context. This issue has been patched in versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0.
Affected products
- angular: through 18.2.14; from 19.0.0 before 19.2.18; from 20.0.0 before 20.3.16; from 21.0.0 before 21.0.7; 21.1.0-next0, 21.1.0-next1, 21.1.0-next2, 21.1.0-next3, 21.1.0-next4 — fixed in 19.2.18, 20.3.16, 21.0.7
How to fix
Upgrade to a fixed version: angular 19.2.18, 20.3.16, 21.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/angular/angular/commit/91dc91bae4a1bbefc58bef6ef739d0e02ab44d56
- https://github.com/angular/angular/pull/66318
- https://github.com/angular/angular/security/advisories/GHSA-jrmj-c5cx-3cw6
- https://cert-portal.siemens.com/productcert/html/ssa-253495.html
- https://cert-portal.siemens.com/productcert/html/ssa-485750.html
Get alerted when CVE-2026-22610 or the next vulnerability affects your stack