What’s Vulnerable › Vulnerabilities
CVE-2026-22615
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-16 · updated 2026-10-26
- Weakness: CWE-20
Description
Due to improper input validation in one of the Eaton Intelligent Power Protector (IPP) XML, it is possible for an attacker with admin privileges and access to the local system to inject malicious code resulting in arbitrary command execution. This security issue has been fixed in the latest version of Eaton IPP software which is available on the Eaton download centre.
Affected products
- Eaton Intelligent Power Protector: before 2.00 — fixed in 2.00
How to fix
Upgrade to a fixed version: Eaton Intelligent Power Protector 2.00. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-22615 or the next vulnerability affects your stack