What’s Vulnerable › Vulnerabilities
CVE-2026-22681: OpenViking < 0.3.4 SSRF via /api/v1/resources
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-21 · updated 2026-10-15
- Weakness: CWE-918
Description
OpenViking before 0.3.4 contains a server-side request forgery vulnerability that allows authenticated low-privilege attackers to access internal network services by submitting arbitrary URLs to the resources API endpoint. Attackers can POST a crafted URL to /api/v1/resources, causing the server to issue outbound HEAD and GET requests with redirects enabled to loopback, RFC 1918, link-local, or cloud metadata addresses, then read back responses through normal content APIs to enumerate and interact with internal services.
Affected products
- Volcengine OpenViking: before 0.3.4 — fixed in 0.3.4
How to fix
Upgrade to a fixed version: Volcengine OpenViking 0.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/volcengine/OpenViking/commit/41e345896d247e43ab78bbcb38b4a5b1b38ef62c
- https://github.com/volcengine/OpenViking/pull/1133
- https://github.com/volcengine/OpenViking/releases/tag/v0.3.4
- https://www.vulncheck.com/advisories/openviking-ssrf-via-api-v1-resources
- https://github.com/volcengine/OpenViking/pull/1133https://github.com/volcengine/OpenViking/pull/1133
Get alerted when CVE-2026-22681 or the next vulnerability affects your stack