What’s Vulnerable › Vulnerabilities
CVE-2026-22704: HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-10 · updated 2026-06-17
- Weakness: CWE-79
Description
HAX CMS helps manage microsite universe with PHP or NodeJs backends. In versions 11.0.6 to before 25.0.0, HAX CMS is vulnerable to stored XSS, which could lead to account takeover. This issue has been patched in version 25.0.0.
Affected products
- haxtheweb haxcms-nodejs: 11.0.6
References
- https://github.com/haxtheweb/haxcms-nodejs/commit/317a8ae29f88be389f7cfeffaef416957122d97e
- https://github.com/haxtheweb/haxcms-nodejs/releases/tag/v25.0.0
- https://github.com/haxtheweb/issues/security/advisories/GHSA-3fm2-xfq7-7778
Get alerted when CVE-2026-22704 or the next vulnerability affects your stack