What’s Vulnerable › Vulnerabilities
CVE-2026-22708: Cursor has a Terminal Tool Allowlist Bypass via Environment Variables
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-14 · updated 2026-06-17
- Weakness: CWE-15
Description
Cursor is a code editor built for programming with AI. Prior to 2.3, hen the Cursor Agent is running in Auto-Run Mode with Allowlist mode enabled, certain shell built-ins can still be executed without appearing in the allowlist and without requiring user approval. This allows an attacker via indirect or direct prompt injection to poison the shell environment by setting, modifying, or removing environment variables that influence trusted commands. This vulnerability is fixed in 2.3.
Affected products
- cursor: before 2.3 — fixed in 2.3
How to fix
Upgrade to a fixed version: cursor 2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-22708 or the next vulnerability affects your stack