What’s Vulnerable › Vulnerabilities
CVE-2026-22711: Stored XSS through system messages in WikiLove
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-07 · updated 2026-07-21
- Weakness: CWE-87
Description
Improper neutralization of alternate XSS syntax vulnerability in The Wikimedia Foundation Mediawiki - Wikilove Extension allows Cross-Site Scripting (XSS).The issue has been remediated on the `master` branch, and in the release branches for MediaWiki versions 1.43, 1.44, and 1.45.
Affected products
- The Wikimedia Foundation Mediawiki - Wikilove Extension: before 1.43 — fixed in 1.43
How to fix
Upgrade to a fixed version: The Wikimedia Foundation Mediawiki - Wikilove Extension 1.43. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/q/Iab86209478a044504f5a6aea0d8c3d14f21c48b3
- https://phabricator.wikimedia.org/T416502
Get alerted when CVE-2026-22711 or the next vulnerability affects your stack