What’s Vulnerable › Vulnerabilities
CVE-2026-22720: VMware Aria Operations stored cross-site scripting vulnerability
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-79
Description
VMware Aria Operations contains a stored cross-site scripting vulnerability. A malicious actor with privileges to create custom benchmarks may be able to inject script to perform administrative actions in VMware Aria Operations. To remediate CVE-2026-22720, apply the patches listed in the 'Fixed Version' column of the 'Response Matrix' of VMSA-2026-0001 https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/36947https:// .
Affected products
- VMware Aria Operations: from 8.0 before 8.18.6 — fixed in 8.18.6
- VMware Cloud Foundation: from 4.0 before 5.2.3; from 9.0 before 9.0.2.0 — fixed in 5.2.3, 9.0.2.0
- VMware Telco Cloud Infrastructure: from 2.2 through 3.0
- VMware Telco Cloud Platform: from 4.0 through 5.1
- VMware Aria Operations: from 8.18.0 before 8.18.6 — fixed in 8.18.6
- VMware Cloud Foundation Operations: from 4.x before 5.2.3; from 9.x.x before 9.0.2 — fixed in 5.2.3, 9.0.2
- VMware Telco Cloud Infrastructure: from 2.0 before 5.2.3 — fixed in 5.2.3
- VMware Telco Cloud Platform: from 4.0 before 5.2.3 — fixed in 5.2.3
How to fix
Upgrade to a fixed version: VMware Aria Operations 8.18.6; VMware Cloud Foundation 5.2.3, 9.0.2.0; VMware Aria Operations 8.18.6; VMware Cloud Foundation Operations 5.2.3, 9.0.2; VMware Telco Cloud Infrastructure 5.2.3; VMware Telco Cloud Platform 5.2.3. Check the vendor advisory for mitigations.
References
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/36947
- https://techdocs.broadcom.com/us/en/vmware-cis/aria/aria-operations/8-18/vmware-aria-operations-8186-release-notes.html
Get alerted when CVE-2026-22720 or the next vulnerability affects your stack