What’s Vulnerable › Vulnerabilities
CVE-2026-22731: Authentication Bypass under Actuator Health groups paths
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-288
Description
Spring Boot applications with Actuator can be vulnerable to an "Authentication Bypass" vulnerability when an application endpoint that requires authentication is declared under a specific path, already configured for a Health Group additional path. This issue affects Spring Boot: from 4.0 before 4.0.3, from 3.5 before 3.5.11, from 3.4 before 3.4.15. This CVE is similar but not equivalent to CVE-2026-22733, as the conditions for exploit and vulnerable versions are different.
Affected products
- Spring Boot: from 3.4.0 before 3.4.15; from 3.5.0 before 3.5.12; from 4.0.0 before 4.0.4 — fixed in 3.4.15, 3.5.12, 4.0.4
- Spring Boot: from 4.0 before 4.0.3; from 3.5 before 3.5.11; from 3.4 before 3.4.15 — fixed in 4.0.3, 3.5.11, 3.4.15
How to fix
Upgrade to a fixed version: Spring Boot 3.4.15, 3.5.12, 4.0.4; Spring Boot 4.0.3, 3.5.11, 3.4.15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-22731 or the next vulnerability affects your stack