What’s Vulnerable › Vulnerabilities

CVE-2026-22733: Authentication Bypass under Actuator CloudFoundry endpoints

Description

Spring Boot applications with Actuator can be vulnerable to an "Authentication Bypass" vulnerability when an application endpoint that requires authentication is declared under the path used by the CloudFoundry Actuator endpoints. This issue affects Spring Security: from 4.0.0 through 4.0.3, from 3.5.0 through 3.5.11, from 3.4.0 through 3.4.14, from 3.3.0 through 3.3.17, from 2.7.0 through 2.7.31.

Affected products

How to fix

Upgrade to a fixed version: Spring Boot 2.7.32, 3.3.18, 3.4.15, 3.5.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-22733 or the next vulnerability affects your stack