What’s Vulnerable › Vulnerabilities

CVE-2026-22748: Potential Security Misconfiguration when Using withIssuerLocation

Description

Vulnerability in Spring Spring Security. When an application configures JWT decoding with NimbusJwtDecoder  or NimbusReactiveJwtDecoder, it must configure an OAuth2TokenValidator<Jwt> separately, for example by calling setJwtValidator.This issue affects Spring Security: from 6.3.0 through 6.3.14, from 6.4.0 through 6.4.14, from 6.5.0 through 6.5.9, from 7.0.0 through 7.0.4.

Affected products

How to fix

Upgrade to a fixed version: Spring Security 6.3.15, 6.4.15, 6.5.10, 7.0.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-22748 or the next vulnerability affects your stack