What’s Vulnerable › Vulnerabilities
CVE-2026-22771: Envoy Extension Policy lua scripts injection causes arbitrary command execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-12 · updated 2026-07-15
- Weakness: CWE-94
Description
Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.5.7 and 1.6.2, EnvoyExtensionPolicy Lua scripts executed by Envoy proxy can be used to leak the proxy's credentials. These credentials can then be used to communicate with the control plane and gain access to all secrets that are used by Envoy proxy, e.g. TLS private keys and credentials used for downstream and upstream communication. This vulnerability is fixed in 1.5.7 and 1.6.2.
Affected products
- envoyproxy gateway: before 1.5.7; from 1.6.0 before 1.6.2 — fixed in 1.5.7, 1.6.2
How to fix
Upgrade to a fixed version: envoyproxy gateway 1.5.7, 1.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/gateway/security/advisories/GHSA-xrwg-mqj6-6m22
- https://access.redhat.com/security/cve/CVE-2026-22771
- https://bugzilla.redhat.com/show_bug.cgi?id=2428735
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-22771.json
Get alerted when CVE-2026-22771 or the next vulnerability affects your stack