What’s Vulnerable › Vulnerabilities
CVE-2026-22773: vLLM is vulnerable to DoS in Idefics3 vision models via image payload with ambiguous dimensions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-10 · updated 2026-06-17
- Weakness: CWE-770
Description
vLLM is an inference and serving engine for large language models (LLMs). In versions from 0.6.4 to before 0.12.0, users can crash the vLLM engine serving multimodal models that use the Idefics3 vision model implementation by sending a specially crafted 1x1 pixel image. This causes a tensor dimension mismatch that results in an unhandled runtime error, leading to complete server termination. This issue has been patched in version 0.12.0.
Affected products
- vllm-project vllm: from 0.6.4 before 0.12.0 — fixed in 0.12.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.12.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-22773 or the next vulnerability affects your stack