What’s Vulnerable › Vulnerabilities
CVE-2026-22774: devalue vulnerable to denial of service due to memory exhaustion in devalue.parse
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-15 · updated 2026-07-15
- Weakness: CWE-405
Description
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From 5.3.0 to 5.6.1, certain inputs can cause devalue.parse to consume excessive CPU time and/or memory, potentially leading to denial of service in systems that parse input from untrusted sources. This affects applications using devalue.parse on externally-supplied data. The root cause is the typed array hydration expecting an ArrayBuffer as input, but not checking the assumption before creating the typed array. This vulnerability is fixed in 5.6.2.
Affected products
- sveltejs devalue: from 5.3.0 before 5.6.2 — fixed in 5.6.2
How to fix
Upgrade to a fixed version: sveltejs devalue 5.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/sveltejs/devalue/commit/e46afa64dd2b25aa35fb905ba5d20cea63aabbf7
- https://github.com/sveltejs/devalue/releases/tag/v5.6.2
- https://github.com/sveltejs/devalue/security/advisories/GHSA-vw5p-8cq8-m7mv
- https://access.redhat.com/errata/RHSA-2026:2144
- https://access.redhat.com/errata/RHSA-2026:2926
- https://access.redhat.com/security/cve/CVE-2026-22774
- https://bugzilla.redhat.com/show_bug.cgi?id=2430095
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-22774.json
Get alerted when CVE-2026-22774 or the next vulnerability affects your stack