What’s Vulnerable › Vulnerabilities
CVE-2026-22777: ComfyUI-Manager is Vulnerable to CRLF Injection in Configuration Handler
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-10 · updated 2026-06-17
- Weakness: CWE-93
Description
ComfyUI-Manager is an extension designed to enhance the usability of ComfyUI. Prior to versions 3.39.2 and 4.0.5, an attacker can inject special characters into HTTP query parameters to add arbitrary configuration values to the config.ini file. This can lead to security setting tampering or modification of application behavior. This issue has been patched in versions 3.39.2 and 4.0.5.
Affected products
- Comfy-Org ComfyUI-Manager: before 3.39.2; from 4.0.3 before 4.0.5 — fixed in 3.39.2, 4.0.5
How to fix
Upgrade to a fixed version: Comfy-Org ComfyUI-Manager 3.39.2, 4.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/Comfy-Org/ComfyUI-Manager/commit/f4fa394e0f03b013f1068c96cff168ad10bd0410
- https://github.com/Comfy-Org/ComfyUI-Manager/security/advisories/GHSA-562r-8445-54r2
Get alerted when CVE-2026-22777 or the next vulnerability affects your stack