What’s Vulnerable › Vulnerabilities
CVE-2026-22778: vLLM leaks a heap address when PIL throws an error
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 18.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-02 · updated 2026-07-15
- Weakness: CWE-532
Description
vLLM is an inference and serving engine for large language models (LLMs). From 0.8.3 to before 0.14.1, when an invalid image is sent to vLLM's multimodal endpoint, PIL throws an error. vLLM returns this error to the client, leaking a heap address. With this leak, we reduce ASLR from 4 billion guesses to ~8 guesses. This vulnerability can be chained a heap overflow with JPEG2000 decoder in OpenCV/FFmpeg to achieve remote code execution. This vulnerability is fixed in 0.14.1.
Affected products
- vllm-project vllm: from 0.8.3 before 0.14.1 — fixed in 0.14.1
How to fix
Upgrade to a fixed version: vllm-project vllm 0.14.1. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/pull/31987
- https://github.com/vllm-project/vllm/pull/32319
- https://github.com/vllm-project/vllm/releases/tag/v0.14.1
- https://github.com/vllm-project/vllm/security/advisories/GHSA-4r2x-xpjr-7cvv
- https://access.redhat.com/errata/RHSA-2026:19712
- https://access.redhat.com/errata/RHSA-2026:30087
- https://access.redhat.com/errata/RHSA-2026:30088
- https://access.redhat.com/errata/RHSA-2026:30089
- https://access.redhat.com/errata/RHSA-2026:3461
- https://access.redhat.com/errata/RHSA-2026:3462
- https://access.redhat.com/errata/RHSA-2026:3713
- https://access.redhat.com/errata/RHSA-2026:3782
Get alerted when CVE-2026-22778 or the next vulnerability affects your stack