What’s Vulnerable › Vulnerabilities
CVE-2026-22785: orval MCP client is vulnerable to a code injection attack.
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-12 · updated 2026-06-17
- Weakness: CWE-77
Description
orval generates type-safe JS clients (TypeScript) from any valid OpenAPI v3 or Swagger v2 specification. Prior to 7.18.0, the MCP server generation logic relies on string manipulation that incorporates the summary field from the OpenAPI specification without proper validation or escaping. This allows an attacker to "break out" of the string literal and inject arbitrary code. This vulnerability is fixed in 7.18.0.
Affected products
- orval-labs orval: before 7.18.0 — fixed in 7.18.0
How to fix
Upgrade to a fixed version: orval-labs orval 7.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/orval-labs/orval/commit/80b5fe73b94f120a3a5561952d6d4b0f8d7e928d
- https://github.com/orval-labs/orval/security/advisories/GHSA-mwr6-3gp8-9jmj
Get alerted when CVE-2026-22785 or the next vulnerability affects your stack