What’s Vulnerable › Vulnerabilities
CVE-2026-22792: 5ire vulnerable to Remote Code Execution (RCE)
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-21 · updated 2026-06-17
- Weakness: CWE-116
Description
5ire is a cross-platform desktop artificial intelligence assistant and model context protocol client. Prior to version 0.15.3, an unsafe HTML rendering permits untrusted HTML (including on* event attributes) to execute in the renderer context. An attacker can inject an `<img onerror=...>` payload to run arbitrary JavaScript in the renderer, which can call exposed bridge APIs such as `window.bridge.mcpServersManager.createServer`. This enables unauthorized creation of MCP servers and lead to remote command execution. Version 0.15.3 fixes the issue.
Affected products
- nanbingxyz 5ire: before 0.15.3 — fixed in 0.15.3
How to fix
Upgrade to a fixed version: nanbingxyz 5ire 0.15.3. Check the vendor advisory for mitigations.
References
- https://github.com/nanbingxyz/5ire/releases/tag/v0.15.3
- https://github.com/nanbingxyz/5ire/security/advisories/GHSA-p5fm-wm8g-rffx
Get alerted when CVE-2026-22792 or the next vulnerability affects your stack