What’s Vulnerable › Vulnerabilities
CVE-2026-22793: 5ire vulnerable to Remote Code Execution (RCE) via ECharts
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-21 · updated 2026-06-17
- Weakness: CWE-94
Description
5ire is a cross-platform desktop artificial intelligence assistant and model context protocol client. Prior to version 0.15.3, an unsafe option parsing vulnerability in the ECharts Markdown plugin allows any user able to submit ECharts code blocks to execute arbitrary JavaScript code in the renderer context. This can lead to Remote Code Execution (RCE) in environments where privileged APIs (such as Electron’s electron.mcp) are exposed, resulting in full compromise of the host system. Version 0.15.3 patches the issue.
Affected products
- nanbingxyz 5ire: before 0.15.3 — fixed in 0.15.3
How to fix
Upgrade to a fixed version: nanbingxyz 5ire 0.15.3. Check the vendor advisory for mitigations.
References
- https://github.com/nanbingxyz/5ire/releases/tag/v0.15.3
- https://github.com/nanbingxyz/5ire/security/advisories/GHSA-wg3x-7c26-97wj
Get alerted when CVE-2026-22793 or the next vulnerability affects your stack