What’s Vulnerable › Vulnerabilities

CVE-2026-22808: Fleet Windows MDM endpoint has a Cross-site Scripting vulnerability

Description

fleetdm/fleet is open source device management software. Prior to versions 4.78.2, 4.77.1, 4.76.2, 4.75.2, and 4.53.3, if Windows MDM is enabled, an unauthenticated attacker can exploit this XSS vulnerability to steal a Fleet administrator's authentication token (FLEET::auth_token) from localStorage. This could allow unauthorized access to Fleet, including administrative access, visibility into device data, and modification of configuration. Versions 4.78.2, 4.77.1, 4.76.2, 4.75.2, and 4.53.3 fix the issue. If an immediate upgrade is not possible, affected Fleet users should temporarily disable Windows MDM.

Affected products

How to fix

Upgrade to a fixed version: fleetdm fleet 4.53.3, 4.75.2, 4.76.2, 4.78.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-22808 or the next vulnerability affects your stack