What’s Vulnerable › Vulnerabilities
CVE-2026-22810: Joplin: Path traversal in OneNote importer allows overwriting arbitrary files
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-18 · updated 2026-07-24
- Weakness: CWE-24
Description
Joplin is an open source note-taking and to-do application that organises notes and lists into notebooks. Versions prior to 3.5.7 contain a path traversal vulnerability in the importer which allows overwriting arbitrary files on disk. The OneNote converter does not sanitize the names of embedded files before writing them to disk. As a result, it's possible for an attacker to create a malicious .one file that includes file names containing ../../, that are then interpreted as part of the target path when extracting attachments from the .one file. This issue has been patched in version 3.5.7.
Affected products
- Joplin: before 3.5.7 — fixed in 3.5.7
- msiemens One2Html: through 1.3.0
How to fix
Upgrade to a fixed version: Joplin 3.5.7. Check the vendor advisory for mitigations.
References
- https://github.com/laurent22/joplin/blob/af5108d70233b1db9410346958c1587cf7c1b16d/packages/onenote-converter/renderer/src/page/embedded_file.rs#L13-L16
- https://github.com/laurent22/joplin/commit/791668455e1aae50501ff57ea4783b3fba9d377c
- https://github.com/laurent22/joplin/pull/13736
- https://github.com/laurent22/joplin/releases/tag/v3.5.7
- https://github.com/laurent22/joplin/security/advisories/GHSA-gcmj-c9gg-9vh6
- https://github.com/laurent22/joplin/security/advisories/GHSA-gcmj-c9gg-9vh6
Get alerted when CVE-2026-22810 or the next vulnerability affects your stack