What’s Vulnerable › Vulnerabilities
CVE-2026-22812: OpenCode's Unauthenticated HTTP Server Allows Arbitrary Command Execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-12 · updated 2026-06-17
- Weakness: CWE-306
Description
OpenCode is an open source AI coding agent. Prior to 1.0.216, OpenCode automatically starts an unauthenticated HTTP server that allows any local process (or any website via permissive CORS) to execute arbitrary shell commands with the user's privileges. This vulnerability is fixed in 1.0.216.
Affected products
- anomalyco opencode: before 1.0.216 — fixed in 1.0.216
How to fix
Upgrade to a fixed version: anomalyco opencode 1.0.216. Check the vendor advisory for mitigations.
References
- https://github.com/anomalyco/opencode/security/advisories/GHSA-vxw4-wv6m-9hhh
- https://github.com/anomalyco/opencode/security/advisories/GHSA-vxw4-wv6m-9hhh
Get alerted when CVE-2026-22812 or the next vulnerability affects your stack