What’s Vulnerable › Vulnerabilities
CVE-2026-22813: Malicious website can execute commands on the local system through XSS in the OpenCode web UI
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-12 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenCode is an open source AI coding agent. The markdown renderer used for LLM responses will insert arbitrary HTML into the DOM. There is no sanitization with DOMPurify or even a CSP on the web interface to prevent JavaScript execution via HTML injection. This means controlling the LLM response for a chat session gets JavaScript execution on the http://localhost:4096 origin. This vulnerability is fixed in 1.1.10.
Affected products
- anomalyco opencode: before 1.1.10 — fixed in 1.1.10
How to fix
Upgrade to a fixed version: anomalyco opencode 1.1.10. Check the vendor advisory for mitigations.
References
- https://github.com/anomalyco/opencode/security/advisories/GHSA-c83v-7274-4vgp
- https://github.com/anomalyco/opencode/security/advisories/GHSA-c83v-7274-4vgp
Get alerted when CVE-2026-22813 or the next vulnerability affects your stack