What’s Vulnerable › Vulnerabilities
CVE-2026-22865: Gradle's failure to disable repositories failing to answer can expose builds to malicious artifacts
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-16 · updated 2026-06-17
- Weakness: CWE-494
Description
Gradle is a build automation tool, and its native-platform tool provides Java bindings for native APIs. When resolving dependencies in versions before 9.3.0, some exceptions were not treated as fatal errors and would not cause a repository to be disabled. If a build encountered one of these exceptions, Gradle would continue to the next repository in the list and potentially resolve dependencies from a different repository. An exception like NoHttpResponseException can indicate transient errors. If the errors persist after a maximum number of retries, Gradle would continue to the next repository. This behavior could allow an attacker to disrupt the service of a repository and leverage another repository to serve malicious artifacts. This attack requires the attacker to have control over a repository after the disrupted repository. Gradle has introduced a change in behavior in Gradle 9.3.0 to stop searching other repositories when encountering these errors.
Affected products
- gradle: before 8.14.4; from 9.0.0 before 9.3.0 — fixed in 8.14.4, 9.3.0
How to fix
Upgrade to a fixed version: gradle 8.14.4, 9.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-22865 or the next vulnerability affects your stack