What’s Vulnerable › Vulnerabilities
CVE-2026-22871: GuardDog Path Traversal Vulnerability Leads to Arbitrary File Overwrite and RCE
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-13 · updated 2026-06-17
- Weakness: CWE-22
Description
GuardDog is a CLI tool to identify malicious PyPI packages. Prior to 2.7.1, there is a path traversal vulnerability exists in GuardDog's safe_extract() function that allows malicious PyPI packages to write arbitrary files outside the intended extraction directory, leading to Arbitrary File Overwrite and Remote Code Execution on systems running GuardDog. This vulnerability is fixed in 2.7.1.
Affected products
- DataDog guarddog: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: DataDog guarddog 2.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/DataDog/guarddog/commit/9aa6a725b2c71d537d3c18d1c15621395ebb879c
- https://github.com/DataDog/guarddog/security/advisories/GHSA-xg9w-vg3g-6m68
Get alerted when CVE-2026-22871 or the next vulnerability affects your stack