What’s Vulnerable › Vulnerabilities

CVE-2026-22892: Insufficient Authorization in Mattermost Jira Plugin Allows Unauthorized Access to Post Attachments

Description

Mattermost versions 11.1.x <= 11.1.2, 10.11.x <= 10.11.9, 11.2.x <= 11.2.1 fail to validate user permissions when creating Jira issues from Mattermost posts, which allows an authenticated attacker with access to the Jira plugin to read post content and attachments from channels they do not have access to via the /create-issue API endpoint by providing the post ID of an inaccessible post.. Mattermost Advisory ID: MMSA-2025-00550

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.10, 11.1.3, 11.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-22892 or the next vulnerability affects your stack