What’s Vulnerable › Vulnerabilities
CVE-2026-22897: QuNetSwitch
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-20 · updated 2026-06-17
- Weakness: CWE-78
Description
A command injection vulnerability has been reported to affect QuNetSwitch. The remote attackers can then exploit the vulnerability to execute arbitrary commands. We have already fixed the vulnerability in the following version: QuNetSwitch 2.0.4.0415 and later
Affected products
- QNAP Systems Inc. QuNetSwitch: from 2.0.1.13077 before 2.0.4.0415 — fixed in 2.0.4.0415
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QuNetSwitch 2.0.4.0415. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-22897 or the next vulnerability affects your stack