What’s Vulnerable › Vulnerabilities
CVE-2026-22900: QuNetSwitch
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-20 · updated 2026-06-17
- Weakness: CWE-798
Description
A use of hard-coded credentials vulnerability has been reported to affect QuNetSwitch. The remote attackers can then exploit the vulnerability to gain unauthorized access. We have already fixed the vulnerability in the following version: QuNetSwitch 2.0.5.0906 and later
Affected products
- QNAP Systems Inc. QuNetSwitch: from 2.0.1.13077 before 2.0.5.0906 — fixed in 2.0.5.0906
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QuNetSwitch 2.0.5.0906. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-22900 or the next vulnerability affects your stack